[FOFO] Le topic des problèmes du forum en version 3.3

Un commentaire sur un article ou sur le site ? Vous voulez dire à Cyrare que vous lui vouez votre vie ? Eventuellement parler (en mal !) d'autres sites ? C'est ici.

Modérateur : DojoSuperHeroes

Avatar de l’utilisateur
meduz'
Grand analyst
Messages : 8945
Inscription : 01 avr. 2005 13:46
Localisation : Devant la Switch
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par meduz' »

J’vais monter un Flarum dans les semaines à viendre pour voir. Ça utilisera un peu le crédit Digital Ocean que je t’ai partagé. Si tu veux tenter avant (ou essayer Discourse), hésite pas. (y)

Avatar de l’utilisateur
meduz'
Grand analyst
Messages : 8945
Inscription : 01 avr. 2005 13:46
Localisation : Devant la Switch
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par meduz' »

Nouvelle page, mais la demande de Mortal est plus importante, donc je la cite :

>>>>>> 👇👇 <<<<<<<
Mortal a écrit :
27 août 2019 14:54
Pour les gens qui ont un souci avec le Captcha : vous avez de l'IPv6 disponible ou pas ?

Je n'arrive à reproduire le problème en v6, mais je pense que j'ai le souci en v4. Pour le moment, toutes les connexions v4 sont présentées via HAProxy donc avec l'adresse IPv6 de cette machine (vous suivez ?). Donc ce que je me dis, c'est qu'en cas de spam un peu violent, le forum partirait du principe que l'IP qui masque tout le monde est problématique.

Je ne sais pas comment la whitelister pour le moment, je cherche.
>>>>>> ☝️☝️ <<<<<<<

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

meduz' a écrit :
27 août 2019 15:34
J’vais monter un Flarum dans les semaines à viendre pour voir. Ça utilisera un peu le crédit Digital Ocean que je t’ai partagé. Si tu veux tenter avant (ou essayer Discourse), hésite pas. (y)
Faut que je teste les deux de toutes manières. Sachant que les points déterminants, c'est :
* capacité de migration depuis phpBB
* maintenabilité à long terme
* ressources nécessaires

Discourse remplit au moins le premier critère, potentiellement le second. Flarum est moins évident sur le 1 et le 2.

Avatar de l’utilisateur
P@B
Shigeru Miyamoto
Messages : 12515
Inscription : 17 avr. 2002 19:52
Localisation : searching - please wait

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par P@B »

Pour l'IPv6, je vais répondre simplement : je n'en ai absolument aucune idée. J'ai le problème en permanence sur mobile, c'est tout ce que je peux dire.

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Donc IPv4. Faut que je reteste une authentification complète depuis un mobile pour voir.

Avatar de l’utilisateur
Cyrare
Satoru Iwata
Messages : 25307
Inscription : 15 avr. 2002 13:04
Localisation : Paris, France
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Cyrare »

Je viens d'avoir le problème en me connectant à l'admin du forum alors que je l'avais pas eu avant. Je pense être en ipv4.

Autre problème, alors que je suis admin, je n'ai pas le droit d'utiliser le bbcode media, j'ai regardé dans l'admin, je trouve rien de particulier (mais cette admin est une horreur)

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Y'a moyen que le BBcode media déconne un peu : il a fallu que je le mette à jour un peu à la hussarde en même temps que le forum.

Je regarde à tête reposée ce soir.

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Fallait réactiver l'extension elle-même (apparemment les autorisations sont dans la base et certaines extensions ne fonctionnant plus, les autorisations étaient pourries) :



EDIT: 1 solved, 1 to go

Avatar de l’utilisateur
P@B
Shigeru Miyamoto
Messages : 12515
Inscription : 17 avr. 2002 19:52
Localisation : searching - please wait

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par P@B »

Cool merci, ça explique pourquoi les liens Twitter et YouTube n'étaient plus convertis en media ! J'ai corrigé vite fait mon topic sur MK Tour du coup. :)
Bon courage pour l'autre, il a l'air légèrement plus corsé à gérer.

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Il va ptet falloir que je révise assez profondément ce que j’avais prévu pour arriver à corriger l’autre. Ou alors, il faut que je whiteliste complètement l’adresse du HAProxy, mais je ne vois pas où (et je ne suis pas certain que ce soit une bonne idée).

Avatar de l’utilisateur
P@B
Shigeru Miyamoto
Messages : 12515
Inscription : 17 avr. 2002 19:52
Localisation : searching - please wait

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par P@B »

En tout cas, pour le moment plus de Captcha !

Avatar de l’utilisateur
MectonLaFlemme
Super Mario 64
Messages : 3589
Inscription : 21 juil. 2009 17:32
Localisation : 2S'Inscrire Mais Baisé Par Le_Systeme

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par MectonLaFlemme »

Idem.
Ils étaient tellement drôles pourtant xD
Les fous ont ouvert la voie. Les sages ont suivi

Avatar de l’utilisateur
Cyrare
Satoru Iwata
Messages : 25307
Inscription : 15 avr. 2002 13:04
Localisation : Paris, France
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Cyrare »

Ouais, j'ai réussi à avoir faux. Comment s'appelle David, j'ai répondu Cage. :rofl:

Avatar de l’utilisateur
P@B
Shigeru Miyamoto
Messages : 12515
Inscription : 17 avr. 2002 19:52
Localisation : searching - please wait

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par P@B »

Moi j'ai cherché quel membre de l'équipe ou du forum s'appelait David... Avant de me rappeler du slogan du Dojo.

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Ces gars-là sont plus David que vous ?

Avatar de l’utilisateur
Le poussin
Super Mario Bros. 3
Messages : 651
Inscription : 19 janv. 2004 00:37
Localisation : Sur Paris
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Le poussin »

Mon avatar ne s'affichait plus dans les topics (remplacé par le "?" par défaut). Il était toujours configuré pour utiliser une URL externe, je suppose que ça vient de là. (L'url était bien accessible, d'ailleurs l'image s'affichait correctement dans la page de configuration de l'avatar).
Après upload manuel, c'est rentré dans l'ordre. Rien de méchant donc, je passais juste prévenir histoire de.
Mon site : Image

Avatar de l’utilisateur
Zwarf
Super Mario Sunshine
Messages : 6035
Inscription : 30 mai 2004 13:45
Localisation : Bayonne

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Zwarf »

Moi c'est un fichier uploadé (en 2004 :n8rd:), je le vois bien dans mon panneau de controle mais dans les sujets il apparait pas :lol:
Image

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Je me demande si ce n'est pas vulgairement une question de cross-chargement d'image http/https.

Avatar de l’utilisateur
KirbyX
Super Mario Maker
Messages : 14883
Inscription : 05 déc. 2002 13:47
Localisation : Green Greens

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par KirbyX »

Plus de captcha ni sur mobile ni sur ordi \o/

Avatar de l’utilisateur
Zwarf
Super Mario Sunshine
Messages : 6035
Inscription : 30 mai 2004 13:45
Localisation : Bayonne

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Zwarf »

:???: J'ai plus l'option pour mettre un avatar externe, c'est normal ?
Image

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

Aucune idée. Je vais regarder de plus près ça dans la journée parce que ça me paraît très très bizarre. C'est en HTTP ou HTTPS ton avatar ?

Avatar de l’utilisateur
Zwarf
Super Mario Sunshine
Messages : 6035
Inscription : 30 mai 2004 13:45
Localisation : Bayonne

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Zwarf »

C'était en http, du coup je l'ai supprimé en me disant que je pourrais le remettre mais dans choix d'avatar je n'ai que l'option "avatar local" donc je ne peux même pas remettre l'url
Image

Avatar de l’utilisateur
Cyrare
Satoru Iwata
Messages : 25307
Inscription : 15 avr. 2002 13:04
Localisation : Paris, France
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Cyrare »

Autoriser les images distantes : Non
Les avatars situés sur un site internet externe.
Attention : l’activation de cette fonctionnalité peut permettre aux utilisateurs de vérifier l’existence de fichiers et de services qui ne sont accessibles que sur le réseau local.
J'ai pas mis sur oui parce que j'ai pas bien compris le risque et comment ça pourrait être vrai. Je te laisse juger. C'est dans Général / Paramètres des avatars

Avatar de l’utilisateur
nazlurf
Yoshi's Island
Messages : 2500
Inscription : 17 déc. 2002 10:19
Localisation : Sélestat

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par nazlurf »

J'imagine que le forum ne genere pas simplement l'avatar avec le lien, mais le forum le telecharge et le restitue (un peu comme un proxy), et du coup, en cherchant des urls des logos de services bien connus, tu verrais sur ton avatar si le service est localement present ou non ...

Avatar de l’utilisateur
Mortal
Satoru Iwata
Messages : 16768
Inscription : 15 avr. 2002 10:17
Localisation : Monde 4, Galaxie 2, Planete 1
Contact :

Re: [FOFO] Le topic des problèmes du forum en version 3.2 (sauf le thème est moche)

Message par Mortal »

C’est exactement l’idée.

Je vais voir ce que ça implique (vu le trafic limité du Dojo, je pense que le risque est lui aussi limité).

Répondre